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1. Create the following worksheet in Excel. 

 

RNO NAME COMPUTER MATHS SCIENCE TOTAL 

531 Mike 57 67 86  

532 Jones 43 78 89  

533 Chris 23 68 57  

534 Shin 56 89 78  

535 York 54 78 67  

 
(a) Fill the TOTAL column. 
(b) Filter the candidate whose ROLLNO > 532 

(c) Filter the candidate whose MATHS > 70. 
 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through G3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with given data for name, computer, maths and science marks. 
 

To Fill the TOTAL column: 

 

4. Select cell G3, click on function button . Insert function dialog box appears. 
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Sum function is already selected, click on OK button. 

5. Function Arguments dialog box appears: 
 

6. Select the range D4:F4 in Number1 textbox and click on OK button. Now formula bar 
will contain a new formula in the G4 cell =SUM (D4:F4) 

7. Now click on  button to get the sum. 
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8. Select the G4 cell. Take the cursor to the bottom-right corner to get a plus symbol. 

Hold it and drag down to autofill the rest of the cells in the column. 
 

To filter the candidates whose ROLLNO > 532 

 
9. Select the complete table. Go to Data menu-> Filter-> AutoFilter. After applying 

AutoFilter to the table, it looks like this: 
 

10. Select the drop-down menu from RNO column and click (Custom…) 
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Custom AutoFilter dialog box appears. 
 

11. In RNO select is greater than from left box and 532 from right box. Click on OK 
button. 

12. The following output is generated that show rows where RNO is greater than 532. 
 

To filter the candidate whose MATHS > 70 

 
13. Now remove filters by deselecting Data->Filter->AutoFilter. 
14. Again select the complete table. Go to Data->Filter->AutoFilter. 
15. In the similar manner Filter the rows where Maths is greater than 70 
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2. The following are the marks obtained by the students of MBA in three Subjects: 

 

Roll No Name ME IT HRM 

1014 Joe 86 95 88 

1015 Clark 45 37 68 

1012 Nice 75 87 57 

1011 Green 65 74 85 

1013 Nick 78 67 46 

 
a) Sort the data by roll no 
b) Using Conditional Formatting list out students who scored More than 65 in IT 

c) Using Conditional Formatting list out students who scored Between 60 and 80 in 

HRM. 
 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through F3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with given data for name, ME, IT and HRM. 

 
To Sort data by Roll No 

 
4. Select the entire table. Go to Data->Sort… A new Sort dialog box appears. Roll No in 

Ascending order is already selected. 
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5. Click OK to get the data sorted in Ascending order of Roll No. 
 

To use Conditional Formatting to list out students who scored More than 65 in IT: 

 
6. Select the range E4 to E8 for IT subject. 
7. Go to Format-> Conditional Formatting; Conditional Formatting Dialog box appears. 

8. In Condition1, Select Call Value Is in the First combo box, Greater than in Second 

combo box and type 65 in third combo box. 
9. Now Click Format… button down, Format Cells dialog box appears; select formatting 

of your choice. 
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10. Click OK to apply formatting. Click OK to apply condition. 

 

To Use Conditional Formatting to list out students who scored Between 60 and 80 in HRM. 

 
11. Select the range F4 to F8 for HRM subject. 
12. Go to Format-> Conditional Formatting; Conditional Formatting Dialog box appears. 

13. In Condition1, Select Call Value Is in the First combo box, select Between in Second 

combo box, type 60 in third combo box and type 80 in the Fourth combo box. 
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14. Now Click Format… button down, Format Cells dialog box appears; select formatting 

of your choice. 

 

15. Click OK to apply formatting. Click OK to apply condition. 
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3. Calculate HRA, DA, IT, PF, PF, Gross Salary, Net Salary from given data in a worksheet: 

 

ENO ENAME Basic Pay HRA DA Gross Pay IT PF Net Pay 

E101 Harry 10000       

E102 Bright 18000       

E103 Sunny 20000       

E104 John 10000       

E105 Mink 19000       

 
Where       

House Rental Allowance HRA is 15% of Basic 

Depreciation Allowance DA is 13% of Basic 
Income Tax  IT is 5% of Basic 
Provident Fund  PF is 9% of Basic 

Gross Pay = Basic Pay + HRA + DA 
  

Net Pay = Gross Pay - IT – PF   

 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through J3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with given data for ENO, ENAME, and Basic Pay. 
 

4. Select cell E4; type =15*D4/100 and hit enter button. 15% of Basic is calculated as 

HRA in the E4 cell. 

5. Again select E4 cell; take cursor to the bottom right corner of the cell till it becomes 
+ hold and drag down to copy the formula to the rest of the rows. 

6. Select cell F4; type =13*D4/100 and hit enter button. 13% of Basic is calculated as DA 

in the F4 cell. 

7. Again select F4 cell; take cursor to the bottom right corner of the cell till it becomes 
+ hold and drag down to copy the formula to the rest of the rows. 

8. Select cell G4; type =D4+E4+F4 and hit enter button. Sum of Basic, HRA and DA is 

calculated as Gross Pay in the G4 cell. 
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9. Again select G4 cell; take cursor to the bottom right corner of the cell till it becomes 

+ hold and drag down to copy the formula to the rest of the rows. 

10. Select cell H4; type =5*D4/100 and hit enter button. 5% of Basic is calculated as IT in 
the H4 cell. 

11. Again select H4 cell; take cursor to the bottom right corner of the cell till it becomes 

+ hold and drag down to copy the formula to the rest of the rows. 
12. Select cell I4; type =9*D4/100 and hit enter button. 9% of Basic is calculated as PF in 

the I4 cell. 
13. Again select I4 cell; take cursor to the bottom right corner of the cell till it becomes + 

hold and drag down to copy the formula to the rest of the rows. 

14. Now the final report after calculation is like this: 
 

 

4. Prepare Pivot Table. 
 

Employee Name Department Salary Rs. 

A Sales 4000 

B Accounts 5000 

C Marketing 6000 

D Sales 4000 

E Accounts 8000 

F Marketing 4000 
 

1. Click on the Start button, point to Programs, followed by Microsoft Office and click 
on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through D3. Highlight and make them in 

Bold with center alignment. 
3. Fill the table with given data for Employee Name, Department, and Salary Rs. 
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4. Select the complete table go to Data menu, select "PivotTable and PivotChart 

Report". 
 

5. A PivotTable wizard should appear. 
 

6. Make sure that the "Microsoft Excel list or database" and "PivotTable" options are 

chosen. Click on the Next button. 
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7. Select the range of data for the pivot table and click on the Next button. 
 

8. Select the position to create the new pivot table. It will automatically default to the cell 
that was highlighted when you started this process. Click on the Layout button. 

9. Now drag the fields that you want to appear in the Page, Row, Column, and Data sections 
of the pivot table. In this example, we've dragged the Department field to the Row 
section and the Salary Rs. to the Data section. 

10. Click on the OK button to continue. 



pg. 15  

 

11. Now click on the Finish button. 

 
 

12. Your pivot table should now appear on new sheet. What this pivot table displays is 

the total Salary for each Department. 
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5. From the table given below, reduce the total expenditure to Rs.16000 by reducing 

sales department’s Expenditure by applying Goal seek. 

 

Department Expenditure Rs. 

Production 4000 

Sales 6000 

Marketing 3000 

Finance 5000 

Total Expenditure 18000 
 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through C3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with given data for Department and Expenditure Rs. 
 

4. Calculate the total expenditure by adding up all departments expenditure in cell C8 

=Sum(C3:C6) 
5. Select cell C8, Go to Tools-> Goal Seek… 



pg. 17  

 

6. Set Cell already contains C8. 
7. Type 16000 in To Value box as we’ve to set Total Expenditure (C8) to 16000 

8. By Changing Cell Sales Expenditure ie C4 
 

9. Click OK 

10. Goal Seek status is displayed. Observe Sales Expenditure ie C4 is adjusted to 4000 to 

get Total expenditure 16000 
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6. Create an excel worksheet to demonstrate absolute and relative cell referencing 
using the following table: 

 

Item Quantity Price Total 

Chair 4 Rs. 600  

Desk 4 Rs. 1700  

Lamp 3 Rs. 500  

 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through E3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with given data for Item, Quantity, and Price. 
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4. To prefix the price with Rs. Tag, Right click on the price column, go to Format Cells… 
5. Select Currency from Category: list box. On the right side select Rs. from combo box 

in Symbol: 

(if you don’t see Rs. in the box then change your Regional settings in the Control 

Panel) 
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6. In the Category: List box, select Custom and type currency format as Rs.#,##0 
 

7. Click OK. 
 
 
 
 
 
 

 
Relative Reference 

 
8. Select cell E4 and calculate the amount by multiplying quantity and price i.e., 

=C4*D4 
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9. Drag down the result in the E4 cell to the rest of the rows. 
 

10. Here in E5 the formula is copied as 

=C5*D5 
11. Similarly E6 contains the formula 

=C6*D6 

 
This is called relative referencing where the row and column references change 
when you copy the formula to another cell because the references are 
actually offsets from the current row and column. 

 
Absolute Reference 

 
12. Assume that the Sales tax is applied on the items purchased. Then we need to 

calculate a fixed sales tax on every item purchased. 
13. For this we use absolute referencing which allows us to calculate sales tax in the 

right way. 
14. Assume that the Sales tax is 10% 

 

15. Sales Tax column is calculated as 

Quantity * Price * Sales Tax 

 
16. For this select cell E4, type 

=C4*D4*$C$9 
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17. Drag down the result to copy the formula 
 

18. Observe you’ll in cell E5 formula is 
=C5*D5*$C$9 

 
19. And cell E6 contains formula 

=C6*D6*$C$9 

 
Here the use of $ before row and column name makes it absolute i.e., the 
row and column references do not change when you copy the formula because 

the reference is to an actual cell address. This is called absolute referencing. 
 

20. Now calculate Total column which is calculated as 
Quantity * Price + Sales Tax 

21. Select cell F4, type formula 
=C4*D4+E4 
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Drag down the result in the F4 cell to the rest of the rows. This is relative 
referencing. Calculation of Sales Tax column is done using the absolute reference 

method. 
 

 

7. Create an excel worksheet to demonstrate the use of mixed referencing with 

multiplication table. 
 

1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through L3. Highlight and make them in 
Bold. 

3. Similarly, select cell B4, type row headings through B13. Highlight & make them in 
Bold. 
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Mixed References 

 
4. To create a multiplication table we make use of mixed references. The formulas in 

the table calculate the multiplication for number 1 to 10. The formula in cell C4 is 

=$B4*C$3 
 

5. Notice that both cell references are mixed. The reference to cell B4 uses an absolute 
reference for the column ($B), and the reference to cell C3 uses an absolute 

reference for the row ($3). 
6. As a result, this formula from cell C4 can be copied down and across, and the calculations 

will be correct. 
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7. For example, the formula in cell F7 is 
=$B7*F$3 

 
If C4 used either absolute or relative references, copying the formula would 
produce incorrect results. 
Formula where either the row or column reference is relative, and the other 

is absolute is called mixed referencing. 
 

8. Create an excel worksheet with the data as follows: 

 
AMOUNT IN CRORES 

YEAR SALES EXPENSE 

1997 250 100 

1998 300 150 

1999 350 200 

2000 430 250 

2001 500 300 

2002 550 350 

2003 600 400 

2004 650 450 

 
Use the above table to create Column Chart 

 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through D3. Highlight and make them in 
Bold. 

3. Fill the table with given data for Year, Sales, and Expense. 
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4. Select the cells C3 to D11, go to Insert menu select Chart… option 
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5. On the Chart Wizard Step 1 of 4, in the Chart Type list box, click Column. In the Chart 

Sub-type list, click the first chart: Clustered Column 
 

6. Click Next 

 
7. In the Chart Wizard Step 2 of 4, make sure the Columns radio button is selected. 
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8. In the Chart Wizard Step 2 of 4, select Series tab, in the Category (X) axis labels, 

select column from B4:B11 by clicking on the  button. 
 

9. Click Next 
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10. In the Chart Wizard Step 3 of 4, Type Yearly Sales & Expenses as Chart Title, Year in 

Category (X) axis and Sales & Expenses in Category (Y) axis. Click Next 

 

11. In step 4 of 4, click Finish 
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9. Create an excel worksheet with the data as follows for Life Expectancy at birth: 

 

COUNTRY CODE TOTAL MALE FEMALE 

Algeria AG 69.24 68.97 70.46 

Netherlands NL 78.15 75.28 81.17 

Venezuela VE 72.95 69.97 76.16 

Australia AS 80.14 77.22 83.23 

Yemen YM 59.98 58.17 61.88 

Switzerland WZ 38.11 36.86 39.4 

 
Use the above table to create Bar Chart 

 

1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through D3. Highlight and make them in 
Bold. 

3. Fill the table with given data for Country, Code, Total, Male and Female. 
 

4. Select the cells D3 to F9, go to Insert menu select Chart… option 
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5. On the Chart Wizard Step 1 of 4, in the Chart Type list box, click Bar. In the Chart Sub- 

type list, click the chart on 1st column, 2nd row: Clustered Bar With 3-D Visual Effect 
 

6. Click Next 
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7. In the Chart Wizard Step 2 of 4, make sure the Columns radio button is selected. 

Click Next 
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8. In the Chart Wizard Step 3 of 4, type Life Expectancy at Birth in Chart Title, Country 

in Category (X) axis and Age in Category (Z) axis. click Next 

 
 

9. In step 4 of 4, click Finish 
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10. Create an excel worksheet with the data as follows: 

 

Age Consumption 

0-5 5% 

6-12 15% 

13-20 25% 

21-35 30 % 

36-60 15% 

above 60 10% 

Use the above table to create Column Chart 
 

1. Click on the Start button, point to Programs, followed by Microsoft Office and click 
on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through C3. Highlight and make them in 
Bold. 

3. Fill the table with given data for Age, and Consumption. 
 

4. Select the complete table, go to Insert menu select Chart… option 
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5. In the Chart Wizard Step 1 of 4, in the Chart Type list box, click Pie. In the Chart Sub- 

type list, click the first. Click Next 

 
6. In the Chart Wizard Step 2 of 4, make sure the Columns radio button is selected. 

Click Next 

7. In the Chart Wizard Step 3 of 4, click Next 
8. In step 4 of 4, click Finish 
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11. Create an excel worksheet to demonstrate macros. 
 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through J3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with sample data for RNO, MOB, ME AFM, MM, SFM, BL, IT and 

calculate the Total. 
 

4. From the Tools menu, point to Macro and click on Record New Macro. 
 

 
 

 
5. From the Record Macro dialog box displayed, enter a name for the macro in the 

Macro name: text box as Toppers and assign a shortcut key t (ctrl+t). 
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6. The default description is displayed in the Description: text box, and contains the 

date and user name. If required, change it. 
7. To begin recording, click OK. 
8. We will filter top 10 students of the class. For this select header rows, from RNO to 

TOT then go to Data->Filter-> AutoFilter 
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9. All the headers are now having small drop down arrows. Click on arrow of TOT field, 

select Top 10 

 
 

10. TOP 10 AutoFilter dialog box appears, make sure 10 is selected in the second box, 
click OK. 
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11. You’ll get 10 students names who got highest marks in the class. 

12. To stop recording, either click the stop button from small menu displayed on the left 

side of the window or from the Tools menu, point to Macro and click on Stop 
Recording. 
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13. Now we’ll create a macro that will remove autoFilter and display all content. For this 

again From the Tools menu, point to Macro and click on Record New Macro 

 

14. From the Record Macro dialog box displayed, enter a name for the macro in the 

Macro name: text box as Stoppers and assign a shortcut key p (ctrl+p). 
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15. To begin recording, click OK. 

16. We will stop filtering top 10 students of the class. For this go to Data->Filter-> 

AutoFilter which will deselect the AutoFilter option. 

 
 

17. To stop recording, from the Tools menu, point to Macro and click on Stop Recording. 
 

 
18. To create a button and assign an Excel macro to it 

 
19. If the Forms toolbar is not displayed, right click on any toolbar that is visible and 

from the pop-up menu that is displayed select Forms. 

20. To create a button, click the Button icon on the Forms toolbar. 
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21. Then, click and drag the mouse to the intended button size. 
22. Rename the button with "Top 10" 
23. Right-click on the button corner and select "Assign Macro…" 

 

24. The Assign Macro dialog box will be displayed. 
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25. Select the Toppers Macro and Click on the OK button. 

26. Similarly create another button and assign Stoppers macro to it and click OK button 

 

27. As a result you’ll have two buttons that displays top 10 students and another resets 
the filter. 

 

 
To run a macro using the Tools Macro command 

• From the Tools menu, point to Macro and click on Macros. 
• From the Macro dialog box displayed, click on the name of the macro you wish to 

run in the Macro name: list box. 

• Click the Run button. 
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To run a macro using the assigned shortcut key 

• Press Ctrl+?, with ? is the letter which you assigned. 

 
To delete a button 

• Click on button and press the Delete key. 
 

12. Create the following worksheet in Excel. 

 

RNO MOB ME AFM MM SFM BL IT TOT AVG GRADE MAX MIN 

1             

2             

3             

4             

5             

 
a) Fill the TOTAL column. 

b) Fill the AVERAGE column. 
c) Grade as 

 
If average >=70, Distinction 
If average >=60 and average <70, 1st class 
If average >=50 and average <60, 2nd class If 

average >=40 and average <50, 3rd class Else
 fail. 

d) Min 
e) Max 

 

1. Click on the Start button, point to Programs, followed by Microsoft Office and click 
on Microsoft Office Excel 2003. 

2. Select cell B3, type the column headings through N3. Highlight and make them in 
Bold with center alignment. 

3. Fill the table with sample data for marks of MOB, ME, AFM, MM, SFM, BL, and IT. 
 

4. Select cell J4, click on  button on formula bar; select Sum from Insert Function 
dialog box. Select cells C4 through I4, select OK the formula will look like 
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=SUM(C4,D4,E4,F4,G4,H4,I4) or =SUM(C4:I4) 
 

5. Drag down the result to copy function on to other rows 

6. Similarly select cell K4 and calculate average as 

 
=AVERAGE (C4,D4,E4,F4,G4,H4,I4) or =AVERAGE(C4:I4) or = J4/7 

 

7. Drag down the result to copy function on to other rows 
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8. To calculate Grade, we will make use of formula in cell L4 as follows 

 
= IF(AND(K4>=70), "Distinction", 

IF(AND(K4>=60,K4<70), "First", 
IF(AND(K4>=50,K4<60), "Second", 
IF(AND(K4>=40,K4<50), "Third", 

"Fail" 
)))) 

 

9. Drag down the result to copy formula on to other rows 
10. Similarly select cell M4 and calculate maximum marks as 

 
=MAX (C4,D4,E4,F4,G4,H4,I4) or =MAX(C4:I4) 

 

11. Drag down the result to copy function on to other rows 
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12. Similarly select cell N4 and calculate minimum marks as 

 
=MIN (C4,D4,E4,F4,G4,H4,I4) or =MIN(C4:I4) 

 

13. Drag down the result to copy function on to other rows 

14. To add title to it, select cells B1 through N1 and click on Merge and Center  button 
from formatting toolbar, Type PROGRESS REPORT, bold the font and increase the 
font size, the final report can be saved to disk or printed. 

 

 

13. Calculate the mean, median, and mode from the following data of marks obtained 
by 10 students. Also demonstrate how to transpose rows into columns. 

 

S. No.: 1 2 3 4 5 6 7 8 9 10 

Marks: 15 32 29 17 32 32 25 29 20 35 
 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 
2. Design the table with given data for SNo and Marks in horizontal format. 
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Move data between rows and columns 

 
3. COPY the table data by selecting the table. 

 

4. Before you paste the copied data, right-click your destination cells and then click 

Paste Special. 
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5. In the Paste Special dialog box, select Transpose, and then click OK. 

You'll find the Transpose check box in the lower-right corner of the dialog box: 
 

Excel pastes the data in vertical format. 
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6. Design the table in the following way: 
 

7. Calculate Mean in cell C15 as 

=AVERAGE(C4:C13) 
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8. Calculate Median in cell C16 as 

=MEDIAN(C4:C13) 
 

9. Calculate Mode in cell C17 as 
=MODE(C4:C13) 
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13. Taj wants to start a business. He estimated that it will cost him Rs. 3,75, 000 to start 
the business and expects to earn a net income of Rs. 75,000, Rs. 1,02,500, Rs. 90,000, Rs. 
62,500, Rs. 1,20,000, and Rs. 1,22,500 respectively, in the first six months. Calculate 
the Internal Rate of Return (IRR) 

 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Design the worksheet as follows: 
 

Function Internal Rate of Return, 

IRR (values, guess) 

3. Click cell D12 and type =IRR( 

4. Select cells D4:D10 and, on the Formula Bar, click the Enter button  
 

5. Right-Click on Cell D12, go to Format cell and select Percentage in Category list box. 
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6. In cell D11, type 12 and click cell D12 
7. In the Formula Bar, change the function to =IRR(D4:D10, D11) and press Enter (you 

shouldn't need any significant difference unless you change the range of cells such as 
D4:D8) 

8. Save the workbook 
 

14. A motorcar is purchased for Rs. 8, 12, 500 that has a life of 5 years and salvage 
value of Rs. 1, 25, 000. Calculate depreciation by straight line method. (Use SLN 
financial function). 

 

 
1. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 

2. Design the worksheet as follows: 
 

3. Click cell C7 and, on the main menu, click Insert -> Function... 
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4. In the Paste Function dialog box, in the Function Category list, click Financial. In the 

Function Name list, double-click SLN. 
 

5. Move the SLN window so you can see the values on the worksheet. 
6. Click the box to the right of Cost and, on the worksheet, click cell C4 
7. In the SLN window, click the box to the right of Salvage and, on the worksheet, click 

cell C5 

8. In the SLN window, click the box to the right of Life and, on the worksheet, click cell 

C6 
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9. Click OK 
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15. Tenley Investments has got investments of Rs. 7, 25, 000 and has a lifetime of 10 years. 

The salvage value of the investment is Rs. 67, 500. Using DDB function; calculate 
depreciation over the life of the investment for first two months. 

 

 
10. Click on the Start button, point to Programs, followed by Microsoft Office and click 

on Microsoft Office Excel 2003. 
11. This will start a new workbook then fill up Sheet as follows: 

 

12. Click cell C8 and, on the main menu, click Insert -> Function... 

13. In the Paste Function dialog box, in the Function Category list, click Financial. In the 

Function Name list, double-click DDB. 
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14. Move the DDB window so you can see the values on the worksheet 

 
15. In the DDB window, Click the box to the right of Cost and, on the worksheet, click cell 

C4 

16. Click the box to the right of Salvage and, on the worksheet, click cell C5 
17. In the DDB window, click the box to the right of Life and, on the worksheet, click cell 

C6 
18. Click the box to the right of Period and, on the worksheet, click cell C7 

19. In the DDB window, click the box to the right of Factor and type 2 (because double- 
declining method always takes 2 as factor even if omitted). Click OK 
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Microsoft 

Access 



pg. 59  

16. Create a database called “dbStudent” and create three tables with names 

tblStudent, tblCourse, and tblStudentCourse respectively with the following 
details: 

 

 

 
1. First, you need to create a directory in My Document with name "database" 
2. Click MS Access icon from Start menu or on your desktop. 

 

3. Select Blank database from right panel. 

Table: tblCourse 

Field Name Data Type 

CourseID Number 

CourseTitle Text 

CreditHour Number 

Description Memo 

 

Table: tblStudent 

Field Name Data 
Type 

 

 

StudentID 
Number 

SName Text 

GPA Number 

 

Table: tblStudentCourse 

Field Name Data Type 

StudentID Number 

CourseID Number 

DateTaken Date/Time 

Seat Text 
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4. Find the directory you just created and type the database name, say “dbStudent” in 
this case, and then click “Create” button. 
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To create tblCourse in Design View: 

5. Double-Click on Create table in Design view 

 

6. Design the table with the given FieldName and DataType. 
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7. Right-click on the CourseID. Set it as Primary Key. 
 

8. Save the table with tblCourse name. 
 



pg. 63  

9. Close the window. Observe tblCourse table is created in dbStudent database. 
 

10. Double-click on the tblCourse to fill the table with sample data. 
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To create tblStudent using Wizard: 

 
11. Double-Click on Create table by using wizard. 

 

 
12. TableWizard window appears. Make sure Business option is selected. 
13. Choose Students from Sample Tables list box. 
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14. Select StudentID, FirstName and PhoneNumber from Sample Fileds list box using 

 button. Renam FirstName to SName and PhoneNumber to GPA 

 

 
15. Give table name as "tblStudent" and make sure "Yes, set a primary key for me." 

option is selected. 
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16. In the next step, Click on Next button. 

 

 
17. In the next step, "Enter data directly into the table." Select Finish. 
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18. Start entering sample data 

 

 
To create tblStudentCourse by entering data: 

 
19. Double-click on the Create table by entering data. 
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20. A new window appears; right-click on the fields and select Rename Column option to 

rename the fields. 

 

21. Rename all the fields as given. Make sure you are not filling the table with any data. 
 

22. Save it with tblStudentCourse name. 
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23. Right-click on tblStudentCourse and select design view. 
 

24. Change the data types as given in the question. In data and time data type. Select 
Format as Medium Date. 
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25. Close above window, you’ll again be seeing window shown below. 

 

26. Double-click on the tblStudentCourse and start entering sample data 
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Three tables are created with three different methods in Access. 
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17. Create a database dbEmployee and create tables tblEmployee and tblDepartment. 

 
• Build Relationships between tblEmployee and tblDepartment. 

• Create a report on tblEmployee. 
 

 

1. First, you need to create a directory in My Document with name "database" 

Table: tblEmployee 

Field Name Data Type 

EmployeeID Number 

EName Text 

Designation Text 

Salary Number 

DepartmentID Number 

 

Table: tblDepartment 

Field Name Data Type 

DepartmentID Number 

DepartmentName Text 

Description Memo 
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2. Click MS Access icon from Start menu or on your desktop. 
 

3. Select Blank database from right panel. 
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4. Find the directory you just created and type the database name, say “dbStudent” in 

this case, and then click “Create” button. 
 

To create tblEmployee in Design View: 
5. Double-Click on Create table in Design view 

 

6. Design the table with the given FieldName and DataType. 
7. Right-click on the EmployeeID. Set it as Primary Key. 
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8. Save the table with tblEmployee name. 
 

9. Close the window. Observe tblEmployee table is created in dbEmployee database. 
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10. Double-click on the tblEmployee to fill the table with sample data. 

 

 

 
To create tblDepartment in using Wizard: 

11. Double-Click on Create table in Design view 
 

12. Design the table with the given FieldName and DataType for second table. 

13. Right-click on the DepartmentID. Set it as Primary Key. 
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14. Save the table with tblDepartment name. 
 

 
15. Close the window. Observe tblDepartment table is created in dbEmployee database. 
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16. Double-click on the tblDepartment to fill the table with sample data. 
 

To Build Relationships between tblEmployee and tblDepartment: 

 
We can establish relationships between two or more tables by associating common fields. In 
the dbEmployee database, the DepartmentID is a common filed in both tables. It is the primary 
filed in tblDepartment table. To establish relationships between the DepartmentID fields in the 
tblEmployee and tblDepartment, proceed as follows: 

 
17. Use the Tools->Relationships menu option to display the Show Table dialog box. 

Once displayed, 

a. select tblDepartment and Click Add 

b. select tblEmployee and Click Add 
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18. Close the Show Table dialog box. 
19. Now drag the table boxes so they are positioned approximately as shown in the 

following illustration. 
20. Establish the join lines (relationships) by selecting DepartmentID in the tblEmployee 

box and draggin to tblDepartment box and release the mouse button. 
 

21. Edit Relationships dialog box appears. Make sure that DepartmentID is selected in 
both the boxes in Edit Relatiobsips dialog box and click Create button. 
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22. Verify that your join lines resemble those shown in the illustration below. The Close 

and click Yes to save the relationships. 

 

To Create a report on tblEmployee: 

 
23. In the Database window, click Reports under Objects. 
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24. Click the New button on the Database window toolbar. 
 

 

In the New Report dialog box you can see six ways to create reports in Microsoft Access: 

 
Design View Begins with blank page. You lay out the report the way you want using 

the design tools in the toolbox. 

Report Wizard Choice of fields, sort criteria, & report layout used. Creates tabular or 

columnar report. 

Columnar AutoReport  One or more records displayed vertically. Selected from a 
single table or query. Each field appears on a separate line with a label to 
its left. 

Tabular AutoReport Rows and columns grouped by field values. Selected from a single 
table or query. The fields in each record appear on one line, & the labels 
print once at the top of each page. 

Chart Wizard Leads you through creation of a report containing a chart and associated 

data. 

Label Wizard Helps you create mailing labels from data. 

 
If you clicked Report Wizard, Chart Wizard, or Label Wizard then you can follow the 
directions in the wizard dialog boxes, 

If you click AutoReport: Tabular or AutoReport: Columnar, MS Access automatically 
creates your report. 

If the resulting report doesn’t look the way you want, you can change it in Design View. 
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25. Select the AutoReport: Tabular and select the table tblEmployee from box given 

below. Remember AutoReport displays all the fields & records in the underlying 
table or query. 

 

 
26. Click OK. tblEmployee report is generated as follows: 
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18. Create Employee salary table and give 5 records. 

 
• The salary field cannot accept > 40,000 
• Sort Salary field 

• Write a query to display the records for salary > 20,000 

 

Table: tblEmp 

Field Name Data type 

EmpNo Number 

EmpName Text 

Designation Text 

Department 
Text 

Salary Number 
 

 
1. First, you need to create a directory in My Document with name "database" 

2. Click on the Start button, point to Programs, followed by Microsoft Office and click 
on Microsoft Office Access 2003. 
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3. Select Blank database from right panel. 
 

4. Find the directory you just created and type the database name, say “dbEmployee” 
in this case, and then click “Create” button. 
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Create tblEmp in Design View: 

5. Double-Click on Create table in Design view 
 

6. Design the table with the given FieldName and DataType. 
7. Right-click on the EmpNo. Set it as Primary Key. 
8. Save the table with tblEmp name. 

 



pg. 85  

9. Observe that the dbEmployee database contains tblEmp table in the database 

window. 
 

Salary field cannot accept > 40,000 
To restrict fields from accepting a range of values, we can give validations rules in Design 
View. 

 
10. To restrict Salary field not to accept Salaray more than 40000, click Salary field of 

tblEmp table, in field propertied, locate Validation Rule and type <= 40000. 
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11. You can fill the table with sample data. If you attempt to give any number greater 

than 40000, it’ll show violation error. 
 

Sort Salary field 

12. To sort Salary field, Select the field content, go to Sort-> Sort Ascending (to sort in 
increasing order of Salary) or Sort Descending. In this example we select Sort 
Ascending 
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Sorted result is displayed in the illustration below: 

 

 
Write a query to display the records for salary > 20,000 

 
13. In the Database window, select Queries under Objects: 

 

 
14. Double click on Create Query in Design View 

Select Query window along with Show Table dialog box appears. 

15. Select table tblEmp and click on Add button. 
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16. Close the Show Table dialog box 
 

17. In the Select Query window, drag and drop fields of tblEmp table in the Filed row. 
18. In the Criteria row, select the cell that intersects with Salary. Type >20000, since our 

query is to display all the records that contain salary >20000, 

 

19. Save and name the query as tblEmp Query1 
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20. To run the query, double-click on the tblEmp Query1 
 

The result will be displayed on the screen. 
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19. Create a database dbBusiness and a table tblBill. 

 

Table: tblBill 

Field Name Data type 

BillNo AutoNumber 

ItemNo Number 

ItemName Text 

ItemPrice Number 

Quantity Number 

Total Number 

 
• Create Query to calculate Total 

• Create a Form using tblBill table. 
• Create Macro to Open Form to Fill data in Table. 

 

 
1. First, you need to create a directory in My Document with name "database" 

2. Click on the Start button, point to Programs, followed by Microsoft Office and click 
on Microsoft Office Access 2003. 
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3. Select Blank database from right panel. 
 

4. Find the directory you just created and type the database name, say “dbBusiness” in 

this case, and then click “Create” button. 
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Create tblBill in Design View: 

5. Double-Click on Create table in Design view 
 

6. Design the table with the given FieldName and DataType. 
7. Right-click on the BillNo. Set it as Primary Key. 

8. Save the table with tblBill name. 
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9. Observe that the dbBusiness database contains tblBill table in the database window. 
 

Query 

10. Create a query that calculates Total = ItemPrice * Quantity. 

11. To do this, in the Database window Click Queries from Objects panel. 
 

12. Click on New button. New Query dialog box appears. 
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13. Select Simple Query Wizard. Click OK 
 

14. As we need to calculate query on Total, select single field Total and click on Next 
button. 
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15. Click Next. 
 

16. Click Next. 
 

17. Click on Finish button. Close the select query window that appears. 
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18. Observe that the dbBusiness database contains tblBill Query in the database 

window. 
 

19. Right-click on the tblBill Query and select Design View 

20. Go to Query menu and select Update Query. 
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You can observe Sort and Show options are replaced with Update to option. 
 

21. Right-click on the first cell next to Update to: and select Build. 

Expression Builder window appears. 

22. Double click on tables and select tblBill from first list box. 
In the second list box all the fields of tblBill are displayed. 

23. Double click on ItemPrice, entry will be added on the above box as 
[tblBill]![ItemPrice] 

24. Click on * from the buttons given below the box. 

25. Double click on Quantity, entry will be added on the above box as 
[tblBill]![Quantity] next to [tblBill]![ItemPrice] * 
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26. Click OK and Save it. 
 

Form 

27. After creating Table and Query, Create a Form in the simple way as follows: 
28. Select Forms from Database window under Objects. 

 

29. Click on New button. 
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30. Select Form Wizard and select tblBill in the box below and click OK. 
 

31. Form wizard opens up, select all fields but the Total field. 
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32. Click Next 

33. Click Next 
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34. Name the form as frmBill. 

35. Click Finish. 

 
Macro 

 
36. Select Macros from Database window under Objects. 

 

37. Use the dropdown menu to select your first action - choose "OpenForm". 
38. In the bottom pane, select the form name you wish to open - choose "frmBill" 
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39. Select Data Mode as Add 
 

40. Use the dropdown menu to select your second action - choose "GoToRecord". 
41. In the bottom pane, choose the record you want to go to - choose "New". 

 
What we're doing here is ensuring that the form doesn't open up a previous record - 
it goes straight to the end and has a blank record ready for you to enter a new 
record (this saves time and unnecessary clicks). 
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42. Run macro, access will open frmBill for you with New Record. You can fill the 

records. 
 

43. Click on Next arrow and fill the details. 
 

44. After entering details in the similar manner, open table tblBill, you can see the 

records are filled with the data but the Total field is not calculated. 
 

45. To calculate Total quickly run your query tblBill Query1 
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46. Access prompts before proceeding, click Yes. 
 

47. Again it prompts say Yes. 
 

48. Now open tblBill, you’ll see Total field is filled with data calculated. 
 


